YouTube Hates Me...

I had all sorts of issues trying to post some videos for the blog on YouTube today.  I have zero experience with video, so this is certainly a learning experience.  I finally struggle through an edit in iMovie and come to find out that if you save a file and then try and upload it to YouTube, it won't work because iMovie saves it as a mp4 and YouTube frowns on that format.  

Second try, output the video directly to YouTube from iMovie.  Google password incorrect.  Wait, what?!?  I know this password is correct.  Several tries later and still not working (pulls hair out and spews a few curse words).  Google "iMovie and YouTube password".  Figure out that there is a super secret password that you must enter into the app to get it to work. Gotta love security measures.  Finally it works!  Ah, but nothing is showing up on Google. Turn to Facebook to rant to all of my friends.  Turns out some of them actually read my status posts and the offers to help come pouring in through posts and private chats (I have awesome friends).  

It's now almost two hours from the first attempt and one of my videos is still processing.  I have 2 more to go (I have to check the freezer to see if I have any Ben and Jerry's Choc Chip Cookie dough to get me through this)!  

If I have success, well then you might be reading this some time in February.  If I don't have success, it won't matter because I'll be in a sugar coma from all of the Ben and Jerry's.

Ok, back to video editing...